Melvin the Mev Mevster

The place where MuddyBuggies Members can post updates to their projects
User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Sun Nov 08, 2020 6:35 pm

Just a bit of a progress report, fuel pipes finished in the engine bay, ordered & received a new braided clutch pipe, seemed easier than trying to modify what was there, only thing is the banjo bolt is a bit long, had to use 4 washers 1 under the head to keep the fluid in the right place but 3 under the panjo otherwise the bolt bottoms out, I could grind 2mm off the bolt but this way works, then I think I'll stick with it.

Then tried to fit the steering column but found the brackets were too far from the bulkhead (one has to be modified anyway), but because of the way I am doing it I'm using a MK1 steering rack with a MK2 column, but as usual it's not that easy. You can't swap over the last part of the column as they are different diameters, you can't swap over the racks because they are completely different mountings & the diameter of the UJ connector is different, not only that they are a different length

Image

So I managed to get some of the distance back by extending the slot where the bolt goes through

Image[

So I think I'm close enough, just waiting for the son to bring me some steel to extend the brackets, then the rest of the time was taken up by making a tray to go under the fuel tank so that if it leaks it can't drop onto the exhaust, some Mev's have passed without having this, some have failed for not having it, so thought best to make one now.

Image

Image

Image

Image

Just needs spraying up now


User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Tue Nov 10, 2020 7:52 pm

Last night I was making brackets to fit a Mazda MX5 fan & cowling to fit on a Nissan Almera radiator, all was good till I noticed that it would foul with the radiator mounting.

Image

Image

Image

Fouling the next bracket to be made

Image

Also a bit close to the coolant pipe

Image

Modified & sprayed again.

Image


User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Wed Nov 11, 2020 6:52 pm

Fitted the bracket back to then radiator to the frame along with the main bracket, need to make up 2 further brackets for the top of the radiator but waiting for some rubber mounts to arrive before I do.

Image

Image

The fitted the petrol drip tray to the subframe & then placed the tank in place, just waiting for the fuel filter to arrive before running the pipes

Image

Image

I've got 3 days off next week I was hoping to get the wiring harness in & consider getting it started, but my fathers boiler has packed in so it looks like I'm fitting a new central heating system instead.

User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Wed Nov 18, 2020 7:01 pm

Took 3 days off to spend on the car but had to fit a new central heating system in my dad's bungalow, we're waiting for the delivery of the last 3 radiators so did a bit on the car.

Made up some more brackets along with some Land Rover rubbers to make the top mounts.

Image

Image

Image

It still moves a little at the bottom, I have the space to fit a couple of stays between the anti roll bar bracket & the bottom bracket, but it's close to the bonnet hinge so want to wait until I get to that point before I make them up.

Then did the hoses, there was a full set of hoses from the MX5 with the kit, so I managed to repurpose them

Image

Image

Finally went to the back & mounted the fuel filter bracket along with a new filter, along with the pipes, waiting for hose clips now, hoping it's all in the right place & doesn't catch the bodywork when I come to fit it.

Image

User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Wed Nov 18, 2020 8:24 pm

Need some foam/rubber padding to put under the tank about 30mm wide, 5mm does anyone know a source?

User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Sun Nov 22, 2020 6:28 pm

Managed to get a bit done today started with finishing the water pipes with clips, apart from the overflow tank that is done, but want to see how much space is left before committing to using the MX5 one, may need a smaller one

Image
Image

Next had a look at the air intake made up a pipe to take the crank breather, for now the air filter is going behind the radiator, need to make up a bracket to mount the MAF, there is also what looks like a air temp sensor, need to find if that can be mounted after the MAF

Image

Clamps had come for the fuel lines so all that was finished off including the rollover vent, then after fitting the viton sheet under the brackets, fitted a couple of Rivnuts for the bodywork when I get that far.

Image
Image
Image

Then fitted new handbrake cables, just need a couple of the spring clamps to hold the cables in place

Image

Finally laid out the wiring, there's a hell of a lot more than I remembered & I'm missing set of 3 relays, I saw them last week, just a tip, don't get old!

Image
Image
Image



User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Tue Nov 24, 2020 8:59 pm

Don't you just love it with no garage

Image

A wise man once told Danny whatever you do get it all working before you start to remove wires, I decided to follow my own advice, I've removed some of the insulation so I can get the wires where I want them.

Connected the battery, I've got ignition & it will spin over, some carb cleaner down the throttle body & it fired, I can hear the fuel pump running so we're getting there. just need to prove out all the lights, I wish now I had not thrown all the old ones away, I could have just plugged them in to test.

Image







User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Fri Nov 27, 2020 8:41 pm

Today was a good day, daylight helps rather than trying to find things with with a floodlight, started by checking the fuses for the hazards, both okay, checked for 12V after the fuse which we got, checked for 12V at the switch 0V, so started to follow the wires back & found it in an unconnected connector, lad was with me & said this one looks similar, plugged them together & we now have hazards & indicators win!

Next was the reverse, same problem, there's a huge connector which I thought had all the wiring for the rear of the car, but nope, there's 2 wires in a separate connector which I hadn't seen connected them & we now have reversing light.

So with all that done I thought I'd try for a start, cranked it over & it didn't want to know, went to check the plugs to find them under water, blew them out & tried again, still not having it, sprayed brake cleaner in throttle body & it fired & tried to run. So checked the fuel pipes, yep there is a 50% of getting them right & I had got them 100% wrong. Swapped them over & tried again, it would fire, run & then die, lad said connect the air inlet hose which has the MAF fitted, did that & it now runs nicely, didn't leave it running long as no coolant.

Which brings me to the only downbeat part of the day, filled the brand new radiator only to find it's leaking, so need to find another, problem is I'm not sure exactly what it is.

User avatar
Phaeton
Posts: 4776
Joined: Mon Jan 29, 2007 9:13 pm
Location: Worksop
Contact:

Re: Melvin the Mev Mevster

Postby Phaeton » Tue Dec 01, 2020 8:00 pm

The other day when making the brackets for the radiator I made a slight mistake I drilled & tapped unfortunately I must has managed to pierce the water chamber, not 100 % sure how, but when I filled it up water started to escape, I was hoping to bodge it until after Christmas & tried to epoxy resin up the error, unfortunately on starting there was a PSSSST & suddenly could see a stream coming out.

Bought a new one, had the option of a NIssen for £3 extra so went with that, unfortunately when it arrived the fan mounting holes where not in quite the same place, so the 2 hours of bending & bracket making the other week was wasted, but that is kit car building

Image
Image

It also must have the top hose in a slightly different place as it now fouled the fan shield so a little angry grinder later

Image

New brackets made, quick spray & will try to get them back on tomorrow.

Image
Image

Wanting to think the harness out a bit more, but need to ensure the car still starts & all lights work each time I remove wires.



Return to “MuddyBuggies Owners Projects”

Who is online

Users browsing this forum: No registered users and 3 guests